4.1 Instalace procedurálního jazyka končí chybou "dynamic load error"

Z PostgreSQL
Verze z 7. 4. 2006, 06:41, kterou vytvořil 82.119.243.73 (diskuse)

(rozdíl) ← Starší verze | zobrazit aktuální verzi (rozdíl) | Novější verze → (rozdíl)
Přejít na: navigace, hledání

Častou příčinnou bývá chybějící DLL pro požadovaný procedurální jazyk. DLL, která jsou dodávány s PostgreSQL pouze zpřístupňují procedurální jazyk, a potřebují DLL jazyka dohledatelné z systémové proměnné PATH. Seznam požadovaných DLL pro jednotlivé procedurální jazyky naleznete v instrukcích k instalaci.

K zjištěbí chybějících knihoven můžete použít "depends tool" fy. Microsoft, který je dostupný v Windows Support Tools, které jsou sice na instalačním CD Windows, ale instalují se samostatně. Pak jednoduše spusťte "depends plpython.dll (pro PL/Python) a dostanete výpis chybějících knihoven.